Уязвимость Redis (CVE-2021-32761)

26 августа 2021 14:08

1. Описание уязвимости:

CVE-2021-32761 Уязвимость резидентной СУБД Redis, связана с целочисленным переполнением в BITFIELD, которое влияет на аутентифицированные клиентские соединения в 32-битных версиях. Эксплуатация уязвимости может позволить нарушителю, действующему удаленно, передать приложению специально созданные данные и вызвать целочисленное переполнение.

Идентификатор Банка данных угроз безопасности информации ФСТЭК России:

2. Возможные меры по устранению уязвимости

— Отказаться от использования СУБД Redis
или
— Установить обновления безопасности для пакета:
Redis
Установка обновлений возможна следующими способами:
а) если компьютер с установленной версией ОС имеет доступ к официальному репозиторию производителя, необходимо запустить от имени администратора обновление командой:
# yum update
После вывода списка обновляемых пакетов согласиться на применение обновлений нажав клавишу Y на клавиатуре. Дождаться завершения установки обновлений и убедиться в отсутствии ошибок при их установке.
б) если компьютер с установленной версией ОС не имеет доступа к официальному репозиторию производителя, необходимо выполнить следующие действия:
Запросить обновленный пакет с зависимостями в Управлении информационных технологий ФССП России.
Проверить целостность и подлинность пакета по инструкции
Установить скачанный пакет(ы) командой:
# yum localinstall *.rpm
После вывода списка обновляемых пакетов согласиться на применение обновлений нажав клавишу Y на клавиатуре. Дождаться завершения установки обновлений и убедиться в отсутствии ошибок при их установке.

Время создания документа: 26 августа 2021 14:09

Версия для печати